Showing 1 Result(s)

Menu Menu. Search Everywhere Threads This forum This thread. Search titles only.

Solved> No Signal with Sapphire RX 580 Pulse

Search Advanced search…. Everywhere Threads This forum This thread. Search Advanced…. Log in. Category 1 Category 2 Category 3 Category 4. Support UI. X Donate Contact us. New posts Trending Search forums. What's new. New posts New profile posts Latest activity.

Current visitors New profile posts Search profile posts Billboard Trophies. Question of the Week: What are some tricks to getting the best performance out of our home computers? Thread starter keksmonsta Start date Aug 11, Sidebar Sidebar. Forums Hardware Graphics Cards. JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding. Previous Next Sort by votes. Aug 11, 5 0 10 0. Hi, like the title says, i am getting no signal from xfx rx xt, when trying to go into bios, with the del key.

I decided to format the windows and do i clean install and first thing first i needed to change the boot priority and to my surprise i had no luck getting a signal from the card, i could see the red light on the mobo indicating that i was in the bios just there was no picture. I can get into windows just fine. So the card has 3x DP and 1x hdmi, nothing works. Maybe if it had dvi i could get a signal, not sure whats going on.

Tried all of the ports. Tried it on my monitor and TV.New AMD driver release doesn't affect my problem. Also nothing with new patch of Apex which came yesterday. I see my mouse cursor and could move it but cant do more things. I just hold my "power" pc button to force shutdown it. Also i changed rx XT to my old GTX and it works like a charm with not a single issue, but lower graphics of course. Sometimes I can play for H without problem then suddenly game freeze, se mouse then need to do a hard reset of pc Power buttonthen start computer agian and suddenly the PC just randomly freeze and need to same agian.

Or just the screen get black and need to restart manualy agian. Using new setup and for now evrything on default settings and still get problems I have this problem too. Exact same problem, instead i have the which is the exact same card essentially but the XT is better binned and overclocked.

Please someone at EA take notice, its super frustrating when the game crashes every mins. July - last edited July.

rx 5700 no signal

I have the same problems too. After playing 1 or a few games, the game would just freeze my pc and it would play the sound of the game over and over again until i press the power button.

Also, ive noticed that whenever i open up youtube while playing apex, the video would start glitching right before apex is about to freeze.

RX 570 not giving a video signal

Same with task manager and discord. Accurate description of the issue. I have identical probelems which seem to only be limited to Apex in my case. The other game I happen to play BF5 works without issues. Especially about the part about other apps starting to glitch on a second monitor before the crash is spot on to what I experience. This widget could not be displayed.

Help us improve Answers HQ! Take Survey No, Thanks. Sign In or Register. See details Show less. Turn on suggestions. Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type. Showing results for.

Search instead for. Do you mean. Zombies Heroes Plants vs. Zombies Heroes Other Plants vs. Zombies Games Plants vs. Zombies Garden Warfare 1 Plants vs. Zombies 2 Other Plants vs. July New AMD driver release doesn't affect my problem. Me too.Forums New posts Search forums. New posts What's new Latest activity New profile posts.

Members Current visitors New profile posts Search profile posts. Log in Register. Search titles only. Search Advanced search…. New posts. Search forums. Log in. Please check out our forum guidelines for info related to our community. JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.

RX losing signal. Thread starter Patmine23 Start date Feb 9, Patmine23 New Member. Joined Feb 5, Messages 15 0. Hello all, Since the Adrenalin update one of my monitors loses input from the card randomly and usually only for a second or 2.

rx 5700 no signal

Those have gone away with the new update which is great, but this new problem is driving me crazy. Any thoughts? Joined Dec 13, Messages 16 0. Joined Jan 31, Messages 3, 0. Joined Jul 2, Messages 30, 6. What specific make and model? Thanks for the replys. Yesterday I decided to use the AMD cleaning utility and reinstall the driver in safe mode.Discussion in ' Graphics Cards ' started by KaapstadJul 10, Log in or Sign up.

Overclockers UK Forums. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More. Show only OP. Sep 7, at PM Mobot Associate Joined: Sep 7, Posts: 2. Aod - could you share your first impressions in terms of thermals, acoustics and boost clocks while gaming? Last edited: Sep 7, Thanks for sharing Aod.

Sep 8, at PM Down, N. Trying to undervolt my gpu with an aggressive fan curve anyone with any good recommendations? Still getting like white snow dots floating in game and when doing stress test after about 10minutes the screen will shut down with no signal but everything else still running as it should. How the worm has turned for Powercolor, the one to avoid so many times in the past, now everyone wants one.

I have to say im loving my red devil. Its absolutely kicking bottom in my games.

rx 5700 no signal

This and my freesynch hz monitor. Im a happy chap.Forums New posts Search forums. New posts What's new Latest activity New profile posts. Members Current visitors New profile posts Search profile posts.

Original Post

Log in Register. Search titles only. Search Advanced search…. New posts. Search forums. Log in. Please check out our forum guidelines for info related to our community. JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding. RX not giving a video signal. Thread starter Games Goblin Start date Aug 19, Games Goblin New Member.

Joined Aug 19, Messages 7 0. Joined Aug 19, Messages 11 0. Hi friend,test. Joined Feb 23, Messages 1, 2. Games Goblin seller is feeding you BS, return the card and demand your money back.

Oh, you flashed it on your own afterwards? Well so much for refund. Joined Jul 2, Messages 30, 6.

Fixing AMD's Broken Drivers

Should of referred to me There are White Silkscreen Rectangles on the back of the card, please take clear pictures of those close up. Hi friend,test this worked: error Chomiq said:.

Games Goblin said:. Thanks for sharing this. My problem is that I can't get a signal out of the card - so I can't boot into windows with the card selected as the one outputting the display Hi, the card was shipped to me from another country, so return shipping costs would be more than what it would be worth and I only tested this card a month after I received it, so the return window may be over as well my fault - I did not get time to put this system together, as I had to find a new case for accommodating the GPU - the old case as a slim atx case I have saved the stock BIOS before flashing the other one - should I share it here?

Maybe the expert members here can look thorough it and see if the BIOS is faulty? Zoom in where it says FC take a picture and then if you look at the back of the card where the blower fan overlaps the card there is another rectangle take a picture of that spot to make sure they are buff clear so the information can be read from them please. That card has been defaced Pull the ram chip heatsink and take a pic of all of then and then a closeup of 1, also take a pic of the pci bracket.Search titles only.

Search Advanced search…. Buyer's Guide. Installation Guide. Guides Start Here! What's new. Latest activity. For a better experience, please enable JavaScript in your browser before proceeding.

The display worked fine in Catalina, but without graphics acceleration of course. I thought I was just going to plug in the card and be up and running. But, I am getting no display signal, but the system is fully booting.

My monitor has DisplayPort 1. I am running CloverLilu 1. All conflicting clover drivers and Kexts have been removed - I have attached my Clover folder. I have tried both iMac18,3 and iMacPro1,1 Smbbios. Any help would be super appreciated! It took me most of a week just getting this system up and running Catalina from High Sierra. Now I just need a display and I am all set! Are you losing the signal as soon as the OS loads or just getting nothing at all at any time?

You should have full graphics functionality with no injection using Whatevergreen 1. Thanks for your help. The signal works through the Apple logo loading the progress bar, but the signal is dropped once the system would normally show the login screen. So weird that it should work and doesn't. Try this and second hdmi port, report back.

Gave it a shot and same thing though. I wonder if this has anything to do with it, they say their Sapphire RX was working until the I am confused, do you have RX or RX ? Sorry - I have a RX Just seems very similar But, I was thinking that link was about the RX - it's theso probably not all that similar.

Gigamaxx Moderator. You must log in or register to reply here. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.

By continuing to use this site, you are consenting to our use of cookies. Accept Learn more….Home Discussions Workshop Market Broadcasts. Change language. Install Steam. So, i just bought new monitor is MAGC and my dp is no signal I've tried several ways and it still doesn't work does this need a driver?

The author of this topic has marked a post as the answer to their question. Click here to jump to that post. Showing 1 - 11 of 11 comments. Did you just recently buy the video card? Originally posted by DaedricPrince :.

The author of this thread has indicated that this post answers the original topic. Have you tried a different DP cable? The cable itself could be at fault. Rumpelcrutchskin View Profile View Posts. Last edited by Rumpelcrutchskin ; 29 Jul, pm. Originally posted by Rumpelcrutchskin :. Per page: 15 30 Date Posted: 29 Jul, pm. Posts: Start a New Discussion. Discussions Rules and Guidelines.

Note: This is ONLY to be used to report spam, advertising, and problematic harassment, fighting, or rude posts. All rights reserved. All trademarks are property of their respective owners in the US and other countries. Some geospatial data on this website is provided by geonames.


Comments

Leave a Reply

Your email address will not be published. Required fields are marked *